Skip to main content
  • In Stock
  • Sold by NeweggBusiness
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Ubiquiti Lite 8-Port, Layer 2 PoE Switch (USW-Lite-8-POE (52W))
Quick View
Ubiquiti Lite 8-Port, Layer 2 PoE Switch (USW-Lite-8-POE (52W))
  • Brand: Ubiquiti Networks
  • Part Number: USW-Lite-8-PoE
  • Format: Desktop
  • Network Management Type: Managed
  • Model #: USW-Lite-8-POE (52W)
  •  
  • $120.00 –
Ubiquiti Flex Mini, 5-Port PoE Layer 2 Switch (USW-Flex-Mini)
Quick View
Ubiquiti Flex Mini, 5-Port PoE Layer 2 Switch (USW-Flex-Mini)
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Part Number: USW-Flex-Mini
  • Format: Desktop
  • Model #: USW-Flex-Mini
  • $21.00 - $29.00
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
Quick View
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: 110
  • Part Number: CBS110-24PP
  • Format: Desktop Wall Mountable Rack-mountable
  • Model #: CBS11024PPNA
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: CBS110-8PP-D-NA
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: 19-inch Rack-mountable Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
  • Primary Ports: 16 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-16T4S
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
Quick View
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
  • Brand: PLANET
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
  • Network Management Type: Unmanaged
  • Model #: IGS-620TF
Ubiquiti UISP-R-Router 8-Port Gigabit PoE MicroPoP Router SFP Advanced Traffic Management
Quick View
Ubiquiti UISP-R-Router 8-Port Gigabit PoE MicroPoP Router SFP Advanced Traffic Management
  • Brand: Ubiquiti
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T 100/ 1000Base-X
  • Network Management Type: Managed
  • Primary Port Count: Total Number of Network Ports: 8 Uplink Port: Yes Modular: Yes Network (RJ-45): Yes Port/Expansion Slot Details: 8 x Gigabit Ethernet PoE 1 x Gigabit Ethernet Expansion Slot Total Number of Expansion Slots: 1.0 Expansion Slot Type: SFP (mini-GBIC) Number of SFP Slots: 1
  • Model #: UISP-R
  •  
  • $197.99 –
Aruba JL820A
Quick View
Aruba JL820A
  • Model #: 190017489704
TP-Link Festa FS352G 52 Port Gigabit Smart Managed Network Switch - 48 RJ45 ports & 4 SFP slots, Free Cloud Access, Static Routing, Vlan, IGMP Snooping, rack-mountable, fanless, Does not work w/ Omada
Quick View
TP-Link
TP-Link Festa FS352G 52 Port Gigabit Smart Managed Network Switch - 48 RJ45 ports & 4 SFP slots, Free Cloud Access, Static Routing, Vlan, IGMP Snooping, rack-mountable, fanless, Does not work w/ Omada
  • Brand: TP-Link
  • Network Management Type: Managed
  • Primary Ports: 48 x 10/100/1000 Mbps RJ45 ports and 4 x Gigabit SFP Slots to provide high-speeds and reliable connections
  • VLAN Support: Yes
  • Model #: Festa FS352G
  • $399.99
  •  
  • $199.98 –
  • Save: 50%
Ubiquiti Pro Max 48, 48-port Layer 3 Switch (USW-Pro-Max-48)
Quick View
Ubiquiti Pro Max 48, 48-port Layer 3 Switch (USW-Pro-Max-48)
  • Brand: Ubiquiti
  • Series: Network Switch
  • Part Number: USW-Pro-Max-48
  • Format: Rackmount
  • Model #: USW-Pro-Max-48
Netgear GS108LP 8-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE, GS108LP-100NAS
Quick View
Netgear GS108LP 8-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE, GS108LP-100NAS
  • Brand: NETGEAR
  • Series: GS108LP
  • Part Number: GS108LP-100NAS
  • Format: Wall Mountable Desktop Rack-mountable
  • Model #: GS108LP-100NAS
  •  
  • $109.99 –
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-621T
Netgear GS108PP 8-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with FlexPoE (123W), GS108PP-100NAS
Quick View
Netgear GS108PP 8-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with FlexPoE (123W), GS108PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS108PP-100NAS
  • Format: Desktop Wall Mountable Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 1000Base-T
  • Model #: GS108PP-100NAS
  •  
  • $139.99 –
ELO-STAND-SELF-SERV-22-24-27-FL
Quick View
ELO-STAND-SELF-SERV-22-24-27-FL
  • Brand: Elo Touch Solutions
  • Model #: E989512
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
  • Brand: HPE Instant On
  • Part Number: R8R50A#ABA
  • Network Management Type: Unmanaged
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Model #: R8R50A#ABA
Lantronix Managed Hardened Multi-Gigabit Ethernet PoE++ Switch - 10G Uplink - 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - SISPM1242-582-LRT
Quick View
Lantronix Managed Hardened Multi-Gigabit Ethernet PoE++ Switch - 10G Uplink - 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - SISPM1242-582-LRT
  • Brand: Lantronix
  • Part Number: SISPM1242-582-LRT
  • Switch Type: managed
  • Standards: 802.1w, 802.1s, 802.1p
  • Model #: SISPM1242-582-LRT
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Brand: D-Link
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Model #: DGS-1005P
  • $57.01 - $57.76
Cisco Catalyst 9200L 48-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-48P-4X-E
Quick View
Cisco Catalyst 9200L 48-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-48P-4X-E
  • Brand: CISCO
  • Series: 9200
  • Part Number: C9200L-48P-4X
  • Network Management Type: Managed
  • Model #: C9200L-48P-4X-E
Netgear GS116LP 16-Port Gigabit Ethernet Unmanaged PoE+ Switch with FlexPoE (76W), GS116LP-100NAS
Quick View
Netgear GS116LP 16-Port Gigabit Ethernet Unmanaged PoE+ Switch with FlexPoE (76W), GS116LP-100NAS
  • Brand: NETGEAR
  • Part Number: GS116PP-100NAS
  • Switch Type: Wall Mountable Rack-mountable Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.1p Class of Service IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.3i 10BASE-T Ethernet IEEE 802.3x Flow Control
  • Model #: GS116LP-100NAS
  •  
  • $189.99 –
Netgear GS310TP 8-Port Gigabit Ethernet PoE+ Smart Managed Essentials Switch with 2 Dedicated SFP Ports (55W), GS310TP-200NAS
Quick View
Netgear Inc.
Netgear GS310TP 8-Port Gigabit Ethernet PoE+ Smart Managed Essentials Switch with 2 Dedicated SFP Ports (55W), GS310TP-200NAS
  • Brand: NETGEAR
  • Format: Desktop
  • Standards: IEEE 802.3at IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.1Q IEEE 802.3ad IEEE 802.3x IEEE 802.1D IEEE 802.1s IEEE 802.1w IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3af IEEE 802.3z
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X Maximum Data Transfer Rate: 128 MB/s
  • Model #: GS310TP-200NAS
  • $159.99
  •  
  • $134.99 –
  • Save: 15%
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
RUCKUS ICX 8100 Compact Switch, 8x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 2x10GbE SFP+ uplink-ports, 124W PoE budget. Power cord not included | ICX8100-C08PF-X
Quick View
Netgear GS324TP 24-Port Gigabit Ethernet PoE+ Smart Managed Essentials Switch with 2 Dedicated SFP Ports (190W), GS324TP-200NAS
Quick View
Netgear Inc.
Netgear GS324TP 24-Port Gigabit Ethernet PoE+ Smart Managed Essentials Switch with 2 Dedicated SFP Ports (190W), GS324TP-200NAS
  • Brand: NETGEAR
  • Series: S350
  • Part Number: GS324TP-200NAS
  • Standards: IEEE 802.3at IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.1Q IEEE 802.3ad IEEE 802.3x IEEE 802.1D IEEE 802.1s IEEE 802.1w IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3af IEEE 802.3z
  • Model #: GS324TP-200NAS
Netgear GS116PP 16-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE (183W), GS116PP-100NAS
Quick View
Netgear GS116PP 16-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE (183W), GS116PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS116PP-100NAS
  • Switch Type: Desktop / Rackmount / Wall-Mount
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: GS116PP-100NAS
  •  
  • $309.99 –
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W, Fanless, TAA Compliant, GS1900-8HPREV03F
Quick View
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W, Fanless, TAA Compliant, GS1900-8HPREV03F
  • Brand: ZyXEL
  • Part Number: GS1900-8HPREV03F
  • Switch Type: Manageable: Yes
  • Format: Desktop Rack-mountable Under Table Wall Mountable
  • Model #: GS19008HPREV03F
  • $114.84 - $115.34
Tripp Lite NGI-M08POE8-L2 Managed 8-Port Managed Industrial Gigabit Ethernet Switch - Layer 2, 1 Gbps, PoE+ 30W, DIN Mount
Quick View
Tripp Lite NGI-M08POE8-L2 Managed 8-Port Managed Industrial Gigabit Ethernet Switch - Layer 2, 1 Gbps, PoE+ 30W, DIN Mount
  • Switch Type: 8-Port Managed Industrial Gigabit Ethernet Switch
  • Format: DIN-Rail Mountable
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: NGI-M08POE8-L2
TRENDnet 8-Port Gigabit Desktop Switch, TEG-S83, 8 x Gigabit RJ-45 Ports, 16Gbps Switching Capacity, Fanless Design, Metal Enclosure, Lifetime Protection, Black
Quick View
TRENDnet 8-Port Gigabit Desktop Switch, TEG-S83, 8 x Gigabit RJ-45 Ports, 16Gbps Switching Capacity, Fanless Design, Metal Enclosure, Lifetime Protection, Black
  • Brand: TRENDnet
  • Model: TEG-S83
  • Part Number: TEG-S83
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab
  • Model #: TEG-S83
  • $18.59 - $19.99
Tripp Lite 8-Port PoE+ 30W Unmanaged Industrial GbE Switch NGI-U08C2POE8
Quick View
Tripp Lite 8-Port PoE+ 30W Unmanaged Industrial GbE Switch NGI-U08C2POE8
  • Switch Type: ethernet
  • Parts: 3 Year
  • Model #: NGIU08C2POE8
TRENDnet TPE-TG82ES (V1.0R) Managed 8-Port Gigabit EdgeSmart PoE+ Switch
Quick View
TRENDnet TPE-TG82ES (V1.0R) Managed 8-Port Gigabit EdgeSmart PoE+ Switch
  • Part Number: TPE-TG82ES
  • Standards: IEEE 802.1d IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Primary Ports: 8 x Gigabit PoE+ ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
  • Model #: TPE-TG82ES (V1.0R)
Aruba 6100 24G 4SFP+ Switch JL678AABA
Quick View
HP
Aruba 6100 24G 4SFP+ Switch JL678AABA
  • Switch Type: other
  • Model #: JL678AABA
ZyXEL 48-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 48 PoE+ Ports at 375W with 2 SFP Uplinks, TAA Compliant, GS1920-48HPv2
Quick View
ZyXEL 48-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 48 PoE+ Ports at 375W with 2 SFP Uplinks, TAA Compliant, GS1920-48HPv2
  • Brand: ZyXEL
  • Part Number: GS1920-48HPv2
  • Switch Type: Manageable
  • Format: Rack-mountable
  • Model #: GS1920-48HPV2