Skip to main content
  • In Stock
  • Sold by NeweggBusiness
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
RUCKUS ICX 8100 1RU Switch, 24x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 4x10GbE SFP+ uplink-ports, 370W PoE budget. Power cord not included | ICX8100-24P-X
Quick View
RUCKUS ICX 8100 1RU Switch, 24x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 4x10GbE SFP+ uplink-ports, 370W PoE budget. Power cord not included | ICX8100-24P-X
  • Brand: Fortinet
  • Series: RUCKUS ICX 8100
  • Part Number: ICX8100-24P-X
  • Switch Type: ICX8100-24P-X
  • Model #: ICX8100-24P-X
Netgear GS316 16-Port Gigabit Ethernet Unmanaged Essentials Switch, GS316-300NAS
Quick View
Netgear Inc.
Netgear GS316 16-Port Gigabit Ethernet Unmanaged Essentials Switch, GS316-300NAS
  • Brand: NETGEAR
  • Part Number: GS316-300NAS
  • Format: Desktop Wall Mountable Rack-mountable
  • Standards: IEEE 802.1p IEEE 802.3az IEEE 802.3ab IEEE 802.3u IEEE 802.3i IEEE 802.3x IEEE 802.3
  • Model #: GS316-300NAS
  • $84.99
  •  
  • $79.99 –
  • Save: 5%
Ubiquiti EdgePoint S16, Application-specific WISP control point (EP-S16)
Quick View
Ubiquiti EdgePoint S16, Application-specific WISP control point (EP-S16)
  • Brand: Ubiquiti Networks
  • Part Number: EP-S16
  • Network Management Type: Managed
  • Primary Ports: 16 x RJ45 + 2 x SFP
  • Model #: EP-S16
  •  
  • $479.00 –
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-16FP-2G
  • Format: Rack-mountable
  • Model #: C1300-16FP-2G
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 65W 1830 (JL811A#ABA)
  • Brand: HPE Instant On
  • Part Number: JL811A#ABA
  • Network Management Type: Smart
  • Primary Ports: 8 x RJ45
  • Model #: JL811A#ABA
Netgear AV Line M4350-32F8V 40-Port Manageable 25 Gigabit Ethernet Switch, XSM4340FV-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-32F8V 40-Port Manageable 25 Gigabit Ethernet Switch, XSM4340FV-100NES
  • Brand: NETGEAR
  • Series: AV Line
  • Part Number: XSM4340FV-100NES
  • Format: Compatible Rack Unit: 1U Form Factor: Rack-mountable Table Top
  • Model #: XSM4340FV-100NES
  •  
  • $4,999.99 –
Aruba CX 6000 48p 10M/100M/1G Class4 PoE 4p SFP 1G 370W Switch 48 Ports - Manageable - Gigabit Ethernet - 4 SFP Slots - 439 W Power Consumption - 370 W PoE Budget - R8N85B#ABA
Quick View
HP
Aruba CX 6000 48p 10M/100M/1G Class4 PoE 4p SFP 1G 370W Switch 48 Ports - Manageable - Gigabit Ethernet - 4 SFP Slots - 439 W Power Consumption - 370 W PoE Budget - R8N85B#ABA
  • Brand: Aruba
  • Part Number: R8N85B#ABA
  • Network Management Type: Managed
  • Primary Ports: 48x Gigabit Ethernet Class 4 PoE+ Ports
  • Model #: R8N85B#ABA
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
  • Brand: HPE Instant On
  • Part Number: JL812A#ABA
  • Network Management Type: Smart
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Model #: JL812A#ABA
Netgear GS316PP 16-Port Gigabit Ethernet Unmanaged PoE+ Essentials Switch (183W), GS316PP-100NAS
Quick View
Netgear GS316PP 16-Port Gigabit Ethernet Unmanaged PoE+ Essentials Switch (183W), GS316PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS316PP-100NAS
  • Format: Desktop Wall Mountable Rack-mountable
  • Standards: IEEE 802.3 CSMA/CD 802.3az Energy Efficient Ethernet
  • Model #: GS316PP-100NAS
  • $234.99
  •  
  • $199.99 –
  • Save: 14%
Netgear GS316P 16-Port Gigabit Ethernet Unmanaged PoE+ Switch with FlexPoE (115W), GS316P-100NAS
Quick View
Netgear GS316P 16-Port Gigabit Ethernet Unmanaged PoE+ Switch with FlexPoE (115W), GS316P-100NAS
  • Brand: NETGEAR
  • Part Number: GS316P-100NAS
  • Format: Desktop Wall Mountable Rack-mountable
  • Standards: IEEE 802.3 CSMA/CD 802.3az Energy Efficient Ethernet
  • Model #: GS316P-100NAS
  • $209.99
  •  
  • $164.99 –
  • Save: 21%
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES101GP2SFW
HPE Networking Instant On Switch 48p Gigabit 4p SFP 1830 (JL814A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 48p Gigabit 4p SFP 1830 (JL814A#ABA)
  • Brand: HPE Instant On
  • Part Number: JL814A#ABA
  • Switch Type: Entry-level, smart-managed, Gigabit Layer 2 switches. Easy-to-deploy, secure and affordable switches, designed for small businesses?looking for cost-effective solution with evolving networking demands. Using the Instant On mobile app or the cloud-based web portal, quickly setup, monitor and manage the 1830 switches. Can also manage the device through the local web GUI. This model has 48 10/100/1000 RJ-45 and 4 SFP 1GbE ports.
  • Network Management Type: Smart
  • Model #: JL814A#ABA
ZyXEL GS1920-8HPv2 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
Quick View
ZyXEL GS1920-8HPv2 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
  • Brand: ZyXEL
  • Series: GS1920
  • Part Number: GS1920-8HPV2
  • Switch Type: Manageable
  • Model #: GS1920-8HPV2
NETGEAR 16-Port High-Power PoE+ Gigabit Ethernet Plus Switch (231W) with 1 SFP Port | GS316EPP
Quick View
NETGEAR 16-Port High-Power PoE+ Gigabit Ethernet Plus Switch (231W) with 1 SFP Port | GS316EPP
  • Brand: NETGEAR
  • Part Number: GS316EPP-100NAS
  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-T EEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.3x Full-duplex Flow Control IEEE 802.3af PoE IEEE 802.3at PoE+
  • Model #: GS316EPP-100NAS
  •  
  • $294.99 –
HPE Networking Instant On Switch 48p Gigabit CL4 PoE 4p SFP 370W 1830 (JL815A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 48p Gigabit CL4 PoE 4p SFP 370W 1830 (JL815A#ABA)
  • Brand: HPE Instant On
  • Part Number: JL815A#ABA
  • Network Management Type: Smart
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Model #: JL815A#ABA
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-20160HPT
Planet GS-4210-24P2S 24-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet GS-4210-24P2S 24-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
  • Brand: PLANET
  • Format: Rackmount
  • Network Management Type: Managed
  • MAC Address Table: 8K entries
  • Model #: GS-4210-24P2S
  •  
  • $420.99 –
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
  • Format: Wall-mount and DIN Rail Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
  • Primary Ports: 6 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5226-4P2T
ERGO BNDL
Quick View
Logitech
ERGO BNDL
  • Model #: LOGIERGOBDL
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
Quick View
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
  • Brand: Allied Telesis
  • Series: GS910
  • Part Number: AT-GS910/8E-10
  • Format: Wall Mountable
  • Model #: AT-GS910/8E-10
Black Box 4-Port Modem Splitter
Quick View
Black Box 4-Port Modem Splitter
  • Weight: 0.32
  • Model #: TL421A
Netgear MS108EUP 8-port Multi-Gigabit (2.5G) Ethernet Ultra 60 PoE++ Easy Smart Managed Switch, MS108EUP-100NAS
Quick View
Netgear Inc.
Netgear MS108EUP 8-port Multi-Gigabit (2.5G) Ethernet Ultra 60 PoE++ Easy Smart Managed Switch, MS108EUP-100NAS
  • Brand: NETGEAR
  • Part Number: MS108EUP-100NAS
  • Format: Wall Mountable Desktop
  • Standards: IEEE 802.3 IEEE 802.3ab IEEE 802.3u IEEE 802.1p IEEE 802.3az IEEE 802.3ad IEEE 802.1Q IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3bt
  • Model #: MS108EUP-100NAS
RUCKUS ICX 7550, 48-port 10/100/1000 Mbps, 2x 40Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-48-E2
Quick View
RUCKUS ICX 7550, 48-port 10/100/1000 Mbps, 2x 40Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-48-E2
  • Brand: Ruckus
  • Part Number: ICX7550-48-E2
  • Format: Stackable
  • Standards: 802.1AB LLDP 802.1D MAC Bridging 802.1p Mapping to Priority Queue 802.1s Multiple Spanning Tree (MST) 802.1w Rapid Reconfiguration of Spanning Tree 802.1x Port-based Network Access Control (PNAC) 802.3 Carrier Sense Multiple Access/Collision Detection (CSMA/CD) 802.3ab 1000BASE-T 802.1 AX-2008 Link Aggregation 802.3ae 10 Gigabit Ethernet 802.3af Power over Ethernet 802.3at Power over Ethernet Plus 802.3bt 4-Pair Power over Ethernet 802.3u 100Base-TX 802.3x Full duplex and Flow Control 802.3z 1000Base-SX/LX 802.3bz Multi-gigabit Ethernet 802.3 MAU MIB (RFC 2239) 802.3ba 40 and 100 Gbps Ethernet 802.1AE-MACsec (with license) 802.3az Energy Efficient Ethernet 802.1Q VLAN Tagging
  • Model #: ICX7550-48-E2
  •  
  • $7,105.99 –
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
  • Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES81GPOEW
OM5 LC/LC MULTIMODE FIBRE CABLE
Quick View
OM5 LC/LC MULTIMODE FIBRE CABLE
  • Weight: 2.0000
  • Model #: LCLCL-20M-OM5-FIBER
Netgear 8-Port Multi-Gigabit (2.5G) Ultra60 PoE++ Ethernet Plus Unmanaged Switch, MS108UP-100NAS
Quick View
Netgear 8-Port Multi-Gigabit (2.5G) Ultra60 PoE++ Ethernet Plus Unmanaged Switch, MS108UP-100NAS
  • Brand: NETGEAR
  • Part Number: MS108UP-100NAS
  • Format: Wall Mountable Desktop
  • Standards: Networking Standards: IEEE 802.3 IEEE 802.3ab IEEE 802.3u IEEE 802.1p IEEE 802.3az IEEE 802.3ad IEEE 802.1Q IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3bt
  • Model #: MS108UP-100NAS
HPE Aruba Networking CX 6200F JL725B#ABA
Quick View
HPE Aruba Networking CX 6200F JL725B#ABA
  • Brand: HPE Aruba Networking
  • Series: CX 6200 Switch Series
  • Part Number: JL725B#ABA
  • Primary Ports: Ports: 24 x 10/100/1000BASE-T Class 4 PoE ports, supporting up to 30W per port 4 x 100M/1/10G SFP+ ports Supports PoE standards IEEE 802.3af, 802.3at 1 x USB-C console port 1 x USB Type-A host port 1 x OOBM 1 x RJ-45 console port
  • Model #: JL725B#ABA