Skip to main content
  • In Stock
  • Sold by NeweggBusiness
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst C1300 Series
  • Part Number: C1300-24MGP-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
  • Model #: C1300-24MGP-4X
Ubiquiti Enterprise 8 PoE, 8-port Layer 3 PoE Switch (USW-Enterprise-8-PoE (120W))
Quick View
Ubiquiti Enterprise 8 PoE, 8-port Layer 3 PoE Switch (USW-Enterprise-8-PoE (120W))
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Part Number: USW-Enterprise-8-PoE
  • Format: Desktop
  • Model #: USW-Enterprise-8-PoE (120W)
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
Quick View
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
  • Brand: Ubiquiti Networks
  • Series: UniFi
  • Part Number: USW-Enterprise-48-PoE (720W)
  • Format: Rackmount
  • Model #: USW-Enterprise-48-PoE (720W)
Cisco Catalyst C1200-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1200-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1200-24FP-4G
  • Format: Rack-mountable
  • Model #: C1200-24FP-4G
Cisco Catalyst 1200-48P-4G Smart Switch, 48 Port GE, PoE, 4x1GE SFP, Limited Lifetime Protection (C1200-48P-4G)
Quick View
Cisco Catalyst 1200-48P-4G Smart Switch, 48 Port GE, PoE, 4x1GE SFP, Limited Lifetime Protection (C1200-48P-4G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • PoE: Yes
  • Model #: C1200-48P-4G
Netgear AV Line M4350-12X12F 12-Port Ethernet Manageable 10 Gigabit Ethernet Switch, XSM4324-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-12X12F 12-Port Ethernet Manageable 10 Gigabit Ethernet Switch, XSM4324-100NES
  • Brand: NETGEAR
  • Part Number: XSM4324-100NES
  • Network Management Type: Managed
  • Primary Ports: 12 x RJ45 + 12 x SFP+
  • Model #: XSM4324-100NES
  •  
  • $3,359.99 –
Cudy 8-Port Gigabit Unmanaged Switch GS108D
Quick View
Cudy 8-Port Gigabit Unmanaged Switch GS108D
  • Brand: Cudy
  • Switch Type: unmanaged, fixed configuration
  • Format: desktop, wall mountable
  • Standards: IEEE 802.3x, IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab
  • Model #: GS108D
Cisco Catalyst C1200-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst C1200-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1200-16P-2G
  • Format: Manageable
  • Model #: C1200-16P-2G
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
Quick View
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Layer: 3
  • Model #: C1200-48T-4G
NETGEAR 8X10G, 8XSFP+ Managed Switch | XSM4316S
Quick View
Netgear Inc.
NETGEAR 8X10G, 8XSFP+ Managed Switch | XSM4316S
  • Brand: NETGEAR
  • Series: ProSafe
  • Network Management Type: Managed
  • Primary Ports: 8 x RJ45 + 8 x SFP+
  • Model #: XSM4316S-100NES
  •  
  • $2,159.99 –
Cisco Catalyst C1200-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 2 Layer Supported
Quick View
Cisco Catalyst C1200-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 2 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1200-8FP-2G
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1200-8FP-2G
Ubiquiti Enterprise 24 PoE, 24-Port Layer 3 PoE Switch with 2.5 GbE PoE+ Output (USW-Enterprise-24-PoE (400W))
Quick View
Ubiquiti Enterprise 24 PoE, 24-Port Layer 3 PoE Switch with 2.5 GbE PoE+ Output (USW-Enterprise-24-PoE (400W))
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Format: Rackmount
  • Network Management Type: Managed
  • Model #: USW-Enterprise-24-PoE (400W)
Cisco Catalyst C1200-8P-E-2G 8-Port Gigabit PoE+ Compliant Managed Network Switch (67W)
Quick View
Cisco Catalyst C1200-8P-E-2G 8-Port Gigabit PoE+ Compliant Managed Network Switch (67W)
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1200-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1200-8P-E-2G
Netgear GS308LP 8-Port Gigabit Ethernet Unmanaged Essentials PoE+ Switch, GS308LP-100NAS
Quick View
Netgear Inc.
Netgear GS308LP 8-Port Gigabit Ethernet Unmanaged Essentials PoE+ Switch, GS308LP-100NAS
  • Brand: NETGEAR
  • Part Number: GS308LP-100NAS
  • Format: Desktop Wall Mountable Enclosure
  • Standards: IEEE 802.3az IEEE 802.1Q IEEE 802.3 IEEE 802.3ab IEEE 802.3u IEEE 802.1p IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3i
  • Model #: GS308LP-100NAS
  •  
  • $74.99 –
Netgear GS116 16-Port Gigabit Ethernet Unmanaged Switch, GS116-300NAS
Quick View
Netgear Inc.
Netgear GS116 16-Port Gigabit Ethernet Unmanaged Switch, GS116-300NAS
  • Brand: NETGEAR
  • Part Number: GS116-300NAS
  • Format: Desktop Wall Mountable Compact
  • Standards: IEEE 802.3az IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x
  • Model #: GS116-300NAS
  •  
  • $99.99 –
Cisco Catalyst C1200-8T-D Ethernet Switch, 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst C1200-8T-D Ethernet Switch, 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported
  • Part Number: C1200-8T-D
  • Format: Desktop
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: C1200-8T-D
Netgear GS308PP 8-Port Gigabit Ethernet Unmanaged PoE+ Essentials Switch with 8-Ports PoE+ (83W), GS308PP-100NAS
Quick View
Netgear GS308PP 8-Port Gigabit Ethernet Unmanaged PoE+ Essentials Switch with 8-Ports PoE+ (83W), GS308PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS308PP-100NAS
  • Format: Desktop Wall Mountable Rack-mountable
  • Standards: IEEE 802.3 CSMA/CD 802.3az Energy Efficient Ethernet
  • Model #: GS308PP-100NAS
  • $129.99
  •  
  • $84.99 –
  • Save: 34%
Netgear GS308 8-Port Gigabit Ethernet Unmanaged Switch, GS308-300PAS
Quick View
Netgear GS308 8-Port Gigabit Ethernet Unmanaged Switch, GS308-300PAS
  • Brand: NETGEAR
  • Part Number: GS308-300PAS
  • Format: Desktop or wallmountable
  • Standards: IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3i 10BASE-T Ethernet IEEE 802.3x Flow Control IEEE 802.1p Priority QoS (all models) IEEE 802.1p Priority QoS and DSCP (except GS308P, GS316) IEEE 802.3 CSMA / CD 802.3az Energy Efficient Ethernet
  • Model #: GS308-300PAS
  •  
  • $20.99 –
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
Quick View
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
  • Brand: Ubiquiti
  • Series: Network Switch
  • Part Number: USW-EnterpriseXG-24
  • Format: Rackmount
  • Model #: USW-EnterpriseXG-24
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-28
ZyXEL GS1350-18HP 16-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 16 PoE+ Ports at 250W with 2 SFP Uplinks
Quick View
ZyXEL GS1350-18HP 16-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 16 PoE+ Ports at 250W with 2 SFP Uplinks
  • Part Number: GS1350-18HP
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair, Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Uplink Interface: Total Number of Network Ports: 16 Uplink Port: Yes Modular: Yes Port/Expansion Slot Details: 16 x Gigabit Ethernet PoE+ 2 x Gigabit Ethernet TP/SFP Combo
  • Model #: GS1350-18HP
Opengear DC Adapter 450041
Quick View
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
Quick View
Transition Networks Unmanaged Hardened Gigabit Ethernet PoE+ Switch
  • Format: DIN Rail Mountable Wall Mountable
  • Primary Port Speed: 1000Base-X 10/100/1000Base-T
  • Weight: 15.20 oz
  • Parts: 5 Year
  • Model #: SISTP1040-342-LRT
  • $296.66 - $298.66
Black Box SW1030A 10-GbE Manual Switch
Quick View
Black Box SW1030A 10-GbE Manual Switch
  • Brand: Black Box
  • Network Management Type: Ethernet Switch
  • Primary Ports: 3 x 10 Gigabit Ethernet Network
  • Primary Port Speed: 10GBase-T
  • Model #: SW1030A
  •  
  • $307.99 –
Extreme Networks - X435 switch 24x10/100/1000BASE-T PoE+ full/half-duplex ports, 4x1G/2.5G unpopulated SFP ports, 1 AC PSU, ExtremeXOS Value Edge license | X435-24P-4S
Quick View
  •  
  • $1,697.99 –
Netgear 8-Port Multi-Gigabit/10G Ethernet Ultra60 PoE++ Smart Switch with 2 SFP+ Ports, MS510TXUP-100NAS
Quick View
Netgear 8-Port Multi-Gigabit/10G Ethernet Ultra60 PoE++ Smart Switch with 2 SFP+ Ports, MS510TXUP-100NAS
  • Brand: NETGEAR
  • Part Number: MS510TXUP-100NAS
  • Format: Rack-mountable Desktop
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: 2.5 Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 1000Base-T 1000Base-X
  • Model #: MS510TXUP-100NAS
  •  
  • $689.99 –
TP-Link Omada Gigabit Multi-Mode Media Converter, TL-MC102
Quick View
  •  
  • $29.99 –
Aruba CX 5420 Switch Chassis - Manageable - 3 Layer Supported - 1000 W Power Consumption - Optical Fiber - PoE Ports - 4U - Compact  - S0U59A
Quick View
Black Box LPB1300 Series Gigabit Ethernet PoE+ Switch LPB1308AR2
Quick View
  • $327.99
  •  
  • $301.99 –
  • Save: 7%