Skip to main content
  • In Stock
  • Sold by NeweggBusiness
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
Quick View
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48P-4G
  • Format: Rackmount
  • Model #: C1300-48P-4G
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48T-4X
  • Format: Rack-mountable
  • Model #: C1300-48T-4X
D-Link 28-Port Layer 2 Smart Managed Gigabit Poe Switch
Quick View
D-Link 28-Port Layer 2 Smart Managed Gigabit Poe Switch
  • Brand: D-LINK BUSINESS PRODUCTS SOLUTIONS
  • Part Number: DGS-1210-28MP
  • Switch Type: Others
  • Format: 28 Port Gigabit 370W PoE
  • Model #: DGS-1210-28MP
Cisco Catalyst C1300-48FP-4X Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - Layer 3 Supported
Quick View
Cisco Catalyst C1300-48FP-4X Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - Layer 3 Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: 1300-48FP-4X
  • Format: Rack-mountable
  • Model #: C1300-48FP-4X
D-Link 52 Port Gigabit Web Smart Switch including 4 SFP ports
Quick View
D-Link 52 Port Gigabit Web Smart Switch including 4 SFP ports
  • Brand: D-Link
  • Series: DGS-1210
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
  • Model #: DGS-1210-52
  •  
  • $395.29 –
Extreme Networks 5420M 48-port Switch with 16 ports 90W multi-rate and 32 ports PoE, Base software license | 5420M-16MW-32P-4YE
Quick View
Extreme Networks 5420M 48-port Switch with 16 ports 90W multi-rate and 32 ports PoE, Base software license | 5420M-16MW-32P-4YE
  • Brand: Extreme Networks
  • Series: 5420M Switches
  • Part Number: 5420M-16MW-32P-4YE
  • Format: Stackable
  • Model #: 5420M-16MW-32P-4YE
  •  
  • $9,448.99 –
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
Quick View
Netgear Inc.
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
  • Brand: NETGEAR
  • Switch Type: managed
  • Format: Desktop
  • Network Management Type: Managed
  • Model #: MSM4214X-100NAS
  •  
  • $1,169.99 –
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40 ~ 75 degrees C operating temperature)
Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40 ~ 75 degrees C operating temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511TS15
  •  
  • $120.99 –
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T2S
Netgear ProSafe M4300-24X 24-Port Manageable 10GBase-T, 10GBase-X - 4 Layer Switch, XSM4324CS-100NES
Quick View
Netgear Inc.
Netgear ProSafe M4300-24X 24-Port Manageable 10GBase-T, 10GBase-X - 4 Layer Switch, XSM4324CS-100NES
  • Brand: NETGEAR
  • Series: ProSafe
  • Format: Stackable
  • Network Management Type: Managed
  • Model #: XSM4324CS-100NES
  •  
  • $3,699.99 –
Cudy 5-Port Gigabit Unmanaged Switch GS105
Quick View
Cudy 5-Port Gigabit Unmanaged Switch GS105
  • Brand: Cudy
  • Switch Type: unmanaged, fixed configuration
  • Format: Desktop
  • Standards: ieee 802.3, ieee 802.3u, ieee 802.3ab
  • Model #: GS105
1x2 DP 1.2 to DisplayPort MST Hub
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
Quick View
PLANET ISW-511S15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-10~60 Degrees C Operating Temperature)
  • Format: DIN Rail Kit and Wall Mount Ear
  • Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-511S15
Netgear GS728TXPv3 24-Port Manageable Gigabit PoE+ Smart Switches with 4 Dedicated 10G SFP+ Ports, GS728TXP-300NAS
Quick View
Netgear Inc.
Netgear GS728TXPv3 24-Port Manageable Gigabit PoE+ Smart Switches with 4 Dedicated 10G SFP+ Ports, GS728TXP-300NAS
  • Brand: NETGEAR
  • Part Number: GS728TXP300NAS
  • Standards: IEEE 802.1x IEEE 802.1Q IEEE 802.3ad IEEE 802.3x IEEE 802.1D IEEE 802.1s IEEE 802.1w IEEE 802.1ab IEEE 802.1p IEEE 802.1as IEEE 802.1Qat IEEE 802.3an IEEE 802.1BA IEEE 802.3i IEEE 802.1Qav IEEE 802.3z IEEE 802.3ae
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 10/100/ 1000Base-T
  • Model #: GS728TXP-300NAS
  •  
  • $489.99 –
NVIDIA Quantum-2 based NDR InfiniBand Switch, 64-ports NDR, 32 OSFP ports, unmanaged, P2C airflow (forward) | MQM9790-NS2F
Quick View
NVIDIA
NVIDIA Quantum-2 based NDR InfiniBand Switch, 64-ports NDR, 32 OSFP ports, unmanaged, P2C airflow (forward) | MQM9790-NS2F
  • Brand: NVIDIA
  • Series: Quantum-2 QM9700 Series
  • Part Number: MQM9790-NS2F
  • Format: Rackmount
  • Model #: MQM9790NS2F
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EP-100NAS
  •  
  • $390.39 –
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
Quick View
Netgear Inc.
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
  • Brand: NETGEAR
  • Part Number: GS724TP-300NAS
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.3 IEEE 802.11ac IEEE 802.3at IEEE 802.3af IEEE 802.1Q IEEE 802.3ad IEEE 802.1D IEEE 802.1w IEEE 802.1s
  • Model #: GS724TP-300NAS
  •  
  • $369.99 –
Ubiquiti Flex 10 GbE, Compact 5-port Layer 2 Switch (USW-Flex-XG)
Quick View
Ubiquiti Flex 10 GbE, Compact 5-port Layer 2 Switch (USW-Flex-XG)
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Part Number: USW-Flex-XG
  • Format: Desktop
  • Model #: USW-Flex-XG
Cisco C9350-24T Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - Twisted Pair
Quick View
Cisco C9350-24T Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - Twisted Pair
  • Brand: CISCO
  • Series: Catalyst 9350
  • Part Number: C9350-24T
  • Switch Type: managed
  • Model #: C9350-24T
  • $7,735.99
  •  
  • $4,744.99 –
  • Save: 38%
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
  • MAC Address Table: 8K
  • Model #: FSD-1008HP
  •  
  • $86.99 –
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Brand: PLANET
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
  • Network Management Type: Managed
  • Model #: WGSW-24040
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS105PP-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105PP-300NAS
  •  
  • $160.33 –
5720 UNIVERSAL SWITCH W/ 48
Quick View
5720 UNIVERSAL SWITCH W/ 48
  • Weight: 33.0000
  • Model #: 5720-48MW
  •  
  • $14,585.99 –
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
Quick View
PLANET FSD-604HP Unmanaged 4-Port 10/100TX 802.3af/at PoE + 2-Port 10/100TX Desktop Switch (60 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Primary Ports: 4-Port 10/100TX 802.3af/at PoE 2-Port 10/100TX
  • Primary Port Speed: 10/100Mbps
  • Model #: FSD-604HP
  •  
  • $50.99 –
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-8P4S
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
Quick View
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
  • Format: DIN Rail Mount
  • Standards: IEEE 802.3 Ethernet / 10Base-T - IEEE 802.3u Fast Ethernet / 100Base-TX - IEEE 802.3ab Gigabit Ethernet / 1000Base-T - IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX - IEEE 802.3x Full-Duplex Flow Control - IEEE 802.3at High Power over Ethernet- IEEE 802.3af Power over Ethernet
  • Primary Ports: 4-port 10/100/1000Base-T RJ-45 with IEEE 802.3af / 802.3at PoE Injector 2-port SFP slot interface, SFP supports 1000Base-X and 100Base-FX transceiver via DIP switch configured
  • PoE: IEEE 802.3af / IEEE 802.3at Power over Ethernet / PSE
  • Model #: IGS-624HPT
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
Quick View
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
  • Brand: StarTech
  • Part Number: I51G-ETHERNET-SWITCH
  • Uplink Interface: RJ45
  • Primary Ports: RJ45
  • Model #:
StarTech VS424HD4K60 4x4 HDMI Matrix Switch w/ Audio & Ethernet Control, 4K 60Hz
Quick View
StarTech VS424HD4K60 4x4 HDMI Matrix Switch w/ Audio & Ethernet Control, 4K 60Hz
  • Network Media: 10 - USB 3.2 Type-A (9 pin, Gen 1, 5Gbps) 1 - USB 3.2 Type-B (9 pin, Gen 1, 5Gbps) 1 - Terminal Block (2 Wire)
  • Uplink Ports: 4
  • Power: 100 - 240 AC Power / Voltage Required
  • Dimensions: Width: 17.2 Inch Depth: 6.3 Inch Height: 1.7 Inch
  • Model #: VS424HD4K60
Netgear GS308EP 8-Port Gigabit Ethernet PoE+ Smart Managed Plus Switch (62W), GS308EP-100NAS
Quick View
Netgear GS308EP 8-Port Gigabit Ethernet PoE+ Smart Managed Plus Switch (62W), GS308EP-100NAS
  • Brand: NETGEAR
  • Part Number: GS308EP-100NAS
  • Format: Wall Mountable Desktop Rack-mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-T IEEE 802.3ab 1000BASE-T EEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.3x Full-duplex Flow Control IEEE 802.3af PoE IEEE 802.3at PoE+
  • Model #: GS308EP-100NAS
  • $99.99
  •  
  • $79.99 –
  • Save: 20%
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
Quick View
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
  • Brand: Ubiquiti Networks
  • Part Number: N-SW
  • Network Management Type: Managed
  • Primary Ports: 4 x RJ45
  • Model #: N-SW