Skip to main content
  • In Stock
  • Sold by NeweggBusiness
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Netgear AV Line M4350-24G4XF 24-Port Manageable 10 Gigabit Ethernet Switch, GSM4328-100NES
Quick View
Netgear Inc.
Netgear AV Line M4350-24G4XF 24-Port Manageable 10 Gigabit Ethernet Switch, GSM4328-100NES
  • Brand: NETGEAR
  • Part Number: GSM4328100NES
  • Standards: IEEE 802.3bt IEEE 802.3af IEEE 802.3at IEEE 802.1as IEEE 802.1Qav IEEE 802.1Qat IEEE 802.1ak IEEE 802.3az IEEE 802.3ad IEEE 802.1AX IEEE 802.1s IEEE 802.1w IEEE 802.1p IEEE 802.1Q IEEE 802.1BA
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Gigabit Ethernet Network Technology: 10GBase-X 10/100/ 1000Base-T
  • Model #: GSM4328-100NES
  •  
  • $2,579.99 –
Extreme Networks 5520-24X-ACDC-BASE
Quick View
Extreme Networks
Extreme Networks 5520-24X-ACDC-BASE
  • Model #: 5520-24X-ACDC-BASE
  • $16,940.00
  •  
  • $11,259.99 –
  • Save: 33%
Extreme Networks 5520 48-port Switch, x Stacking/QSFP28 ports, Base software included | 5520-48T
Quick View
Extreme Networks
Extreme Networks 5520 48-port Switch, x Stacking/QSFP28 ports, Base software included | 5520-48T
  • Brand: Extreme Networks
  • Network Management Type: Managed
  • Primary Ports: • 48 x 10/100/1000BASE-T ports ? Full / Half-Duplex (autosensing) ? MACsec-capable • 2 x Stacking/QSFP28 ports* (unpopulated) • 1 x Serial console port (RJ-45) • 1 x 10/100/1000BASE-T out-of-band management port • 2 x USB A ports for management or external USB flash • 1 x USB Micro-B console port • 1 x VIM slot
  • Model #: 5520-48T
  •  
  • $5,679.99 –
Extreme Networks 5520-48W: High-Performance 48-Port 1GbE Switch with Modular Uplinks, PoE, and Advanced Routing Capabilities
Quick View
Extreme Networks
Extreme Networks 5520-48W: High-Performance 48-Port 1GbE Switch with Modular Uplinks, PoE, and Advanced Routing Capabilities
  • Brand: Extreme Networks
  • Series: 5520
  • Network Management Type: Managed
  • Primary Ports: • 48 x 10/100/1000BASE-T 802.3bt (90W) ports ? Full / Half-Duplex (autosensing) ? MACsec-capable • 2 x Stacking/QSFP28 ports* (unpopulated) • 1 x Serial console port (RJ-45) • 1 x 10/100/1000BASE-T out-of-band management port • 2 x USB A ports for management or external USB flash • 1 x USB Micro-B console port • 1 x VIM slot
  • Model #: 5520-48W
  • $7,826.99
  •  
  • $7,390.99 –
  • Save: 5%
Extreme Networks 5520 24-port SFP+ Switch,  24 x 100Mb/1Gb/10Gb SFP+ ports, includes 2 Stacking/QSFP28 ports | 5520-24X-BASE
Quick View
Extreme Networks
Extreme Networks 5520 24-port SFP+ Switch, 24 x 100Mb/1Gb/10Gb SFP+ ports, includes 2 Stacking/QSFP28 ports | 5520-24X-BASE
  • Brand: Extreme Networks
  • Series: 5520 Series
  • Part Number: 5520-24X-BASE
  • Management Interface: 24 x 100Mb/1Gb/10Gb SFP+ ports, includes 2 Stacking/QSFP28 ports
  • Model #: 5520-24XBASE
  • $16,940.00
  •  
  • $11,310.99 –
  • Save: 33%
Mellanox Spectrum-based 25GbE/100GbE 1U Open Ethernet Switch w/ Mellanox Onyx, 18 SFP28 and 4 QSFP28 ports, 2 Power Supplies (AC), short depth, x86 quad core, P2C airflow | MSN2010-CB2F
Quick View
Open Box Mellanox Spectrum-based 25GbE/100GbE 1U Open Ethernet Switch w/ Mellanox Onyx, 18 SFP28 and 4 QSFP28 ports, 2 Power Supplies (AC), short depth, x86 quad core, P2C airflow | MSN2010-CB2F
  • Brand: Mellanox
  • Series: SN2000 Series
  • Part Number: MSN2100-CB2F
  • Standards: 802.1D Bridging and Spanning Tree 802.1p QOS 802.1Q VLAN Tagging 802.1w Rapid Spanning Tree 802.1s Multiple Spanning Tree Protocol 802.1AB Link Layer Discovery Protocol 802.1Qaz ETS 802.1Qbb PFC 802.3ad Link Aggregation with LACP 802.3ba 40 and 100 Gigabit Ethernet 802.3x Flow Control 1000BASE-KX 802.3ae 10 Gigabit Ethernet
  • Model #: MSN2100-CB2F
  •  
  • $8,999.99 –
HP JL259A#ABA 2930F 24G 4SFP Switch
Quick View
HP JL259A#ABA 2930F 24G 4SFP Switch
  • Primary Ports: (24) RJ-45 autosensing 10/100/1000 ports (4) SFP
  • Dimensions: 1.73" x 17.42" x 7.88"
  • Weight: 5.31 lbs.
  • Package Contents: (1) Aruba 2930F 24G 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
  • Model #: JL259A#ABA
Netgear AV Line M4250-10G2F-PoE+ 8x1G PoE+ 125W 2x1G and 2xSFP Managed Switch, GSM4212P-100NAS
Quick View
Netgear Inc.
Netgear AV Line M4250-10G2F-PoE+ 8x1G PoE+ 125W 2x1G and 2xSFP Managed Switch, GSM4212P-100NAS
  • Brand: NETGEAR
  • Part Number: GSM4212P-100NAS
  • Format: Rackmount
  • Network Management Type: Managed
  • Model #: GSM4212P-100NAS
  •  
  • $749.99 –
Netgear GS108MX 8-Port 10 Gigabit Ethernet Unmanaged Switch, GS108MX-100NAS
Quick View
Netgear Inc.
Netgear GS108MX 8-Port 10 Gigabit Ethernet Unmanaged Switch, GS108MX-100NAS
  • Brand: NETGEAR
  • Series: GS108X
  • Part Number: GS108MX-100NAS
  • Format: Desktop/Wall-mount
  • Model #: GS108MX-100NAS
  • $139.99
  •  
  • $119.99 –
  • Save: 14%
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
Quick View
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
  • Brand: D-Link
  • Format: Rackmount
  • Standards: 802.3 Ethernet, 802.3u Fast Ethernet, 802.3x Flow Control, 802.3ab Gigabit Ethernet, 802.1p QoS
  • Network Management Type: Unmanaged
  • Model #: DGS-1016D
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Layer: 2
  • Model #: CBS220-8T-E-2G
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
Quick View
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
  • Brand: CISCO
  • Series: Catalyst
  • Part Number: C1300-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1300-8P-E-2G
Black Box Gigabit Ethernet (1000-Mbps) PoE+ Switch - (1) 10/100/1000-Mbps Copper RJ45 - (4) RJ45 PoE+  LPB1205A-R2
Quick View
Black Box Gigabit Ethernet (1000-Mbps) PoE+ Switch - (1) 10/100/1000-Mbps Copper RJ45 - (4) RJ45 PoE+ LPB1205A-R2
  • Brand: Black Box Innovations
  • Model: LPB1205A-R2
  • Part Number: LPB1205A-R2
  • Model #: LPB1205A-R2
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EPP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EPP-100NAS
  •  
  • $339.99 –
Extreme Networks 5520 48-port 90w PoE w/ 12 ports multi-rate Switch, 2 x Stacking/QSFP28 ports, Base software included | 5520-12MW-36W
Quick View
Extreme Networks 5520 48-port 90w PoE w/ 12 ports multi-rate Switch, 2 x Stacking/QSFP28 ports, Base software included | 5520-12MW-36W
  • Brand: Extreme Networks
  • Series: 5520 Series
  • Part Number: 5520-12MW-36W
  • Network Management Type: Managed
  • Model #: 5520-12MW-36W
  • $14,512.00
  •  
  • $9,509.99 –
  • Save: 34%
Planet IGSW-24040T Industrial 24-Port 10/100/1000 Mbps with 4-Port Shared SFP Managed Gigabit Switch
Quick View
Planet IGSW-24040T Industrial 24-Port 10/100/1000 Mbps with 4-Port Shared SFP Managed Gigabit Switch
  • Format: Stackable
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
  • Primary Ports: 24 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24 Compatible with 100Base-FX SFP, 1 x RS-232 DB9 serial port (115200, 8, N, 1)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGSW-24040T
  •  
  • $776.99 –
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet GS-4210-16UP4C 16-Port 10/100/1000T Ultra PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper ports with 6-Port IEEE 802.3at / af / Ultra PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatible with 100BASE-FX SFP...
  • Model #: GS-4210-16UP4C
Extreme Networks 5520 24-port 90w PoE Switch, 2 x Stacking/QSFP28 ports, Base software included | 5520-24W
Quick View
Extreme Networks
Extreme Networks 5520 24-port 90w PoE Switch, 2 x Stacking/QSFP28 ports, Base software included | 5520-24W
  • Brand: Extreme Networks
  • Series: 5520 Series
  • Part Number: 5520-24W
  • Network Management Type: Managed
  • Model #: 552024W
  • $7,204.00
  •  
  • $4,767.99 –
  • Save: 33%
Extreme Networks 5520 24-port SFP+ Switch, 24 x 100Mb/1Gb/10Gb SFP+ ports, includes 2 Stacking/QSFP28 ports | 5520-24X
Quick View
Extreme Networks
Extreme Networks 5520 24-port SFP+ Switch, 24 x 100Mb/1Gb/10Gb SFP+ ports, includes 2 Stacking/QSFP28 ports | 5520-24X
  • Brand: Extreme Networks
  • Series: 5520 Series
  • Part Number: 5520-24X
  • Network Management Type: Managed
  • Model #: 5520-24X
  • $16,585.00
  •  
  • $11,135.99 –
  • Save: 32%
Netgear GS305 5-Port Gigabit Ethernet SOHO Unmanaged Essentials Switch, GS305-300PAS
Quick View
Netgear GS305 5-Port Gigabit Ethernet SOHO Unmanaged Essentials Switch, GS305-300PAS
  • Brand: NETGEAR
  • Part Number: GS305-300PAS
  • Format: Desktop Wall mountable
  • Standards: IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3i 10BASE-T Ethernet IEEE 802.3x Flow Control IEEE 802.1p Priority QoS IEEE 802.1p Priority QoS and DSCP IEEE 802.3 CSMA/CD 802.3az Energy Efficient Ethernet
  • Model #: GS305-300PAS
  • $15.99
  •  
  • $13.49 –
  • Save: 15%
  • $13.22
Netgear GS305EPP 5-Port Gigabit Ethernet Easy Smart Essentials PoE Manageable Switch, GS305EPP-100NAS
Quick View
Netgear Inc.
Netgear GS305EPP 5-Port Gigabit Ethernet Easy Smart Essentials PoE Manageable Switch, GS305EPP-100NAS
  • Brand: NETGEAR
  • Part Number: GS305EPP-100NAS
  • Format: Desktop
  • Standards: IEEE 802.3 Ethernet IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-T IEEE 802.3ab 1000BASE-T EEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.3x Full-duplex Flow Control
  • Model #: GS305EPP-100NAS
  •  
  • $92.99 –
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
Quick View
BRAINBOXES SW-108 EMBEDDED 8PORT ETHERNET SWITCH
  • Switch Type: Consumer Electronics
  • Weight: 0.4
  • Model #: SW-108
Zyxel 48-port GbE PoE Lite-L3 Smart Managed Switch with 4 10G Uplink - 48 Ports - Manageable - 10 Gigabit Ethernet - 470.10 W Power Consumption - 375 W PoE Budget (XGS1935-52HP)
Quick View
Zyxel 48-port GbE PoE Lite-L3 Smart Managed Switch with 4 10G Uplink - 48 Ports - Manageable - 10 Gigabit Ethernet - 470.10 W Power Consumption - 375 W PoE Budget (XGS1935-52HP)
  • Brand: ZyXEL
  • Model: XGS1935-52HP
  • Part Number: XGS1935-52HP
  • Primary Ports: 48 x 100/1000BASE-T Gigbit Ethernet PoE+ RJ-45 Network Port 4 x 10 Gigbit Ethernet SFP+ Expansion Slot
  • Model #: XGS1935-52HP
Axis D8248 Managed PoE++ 48-Port Switch (02620-004)
Quick View
Axis D8248 Managed PoE++ 48-Port Switch (02620-004)
  • Brand: Axis
  • Part Number: 02620-004
  • Network Management Type: Managed
  • Model #: 02620-004
Epiphan Pearl Mini All-In-One Video Production System #ESP1440
Quick View
  •  
  • $3,750.99 –
Manhattan 153201 4K @ 60 Hz DisplayPort to HDMI Cable (6-Foot)
Quick View
Manhattan 153201 4K @ 60 Hz DisplayPort to HDMI Cable (6-Foot)
  • Brand: MANHATTAN
  • Switch Type: Others
  • Model #: 153201
  • $19.77 - $25.77
Aruba 6300M 24SR5 CL6 PoE 4SFP56 Swch
Quick View
Aruba 6300M 24SR5 CL6 PoE 4SFP56 Swch
  • Weight: 17.2
  • Model #: JL660A
  •  
  • $13,499.00 –
Black Box Gigabit Ethernet Managed Switch - (24) RJ-45 (2) SFP
Quick View
Black Box Gigabit Ethernet Managed Switch - (24) RJ-45 (2) SFP
  • Brand: Black Box
  • Switch Type: managed
  • Format: Desktop Rack-mountable
  • Network Management Type: Ethernet Switch
  • Model #: LGB2126A