Skip to main content
  • In Stock
  • Sold by NeweggBusiness
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
Sort By:
View:
Netgear GS724T 24-Port Manageable Gigabit Ethernet Smart Switch, GS724T-600NAS
Quick View
Netgear Inc.
Netgear GS724T 24-Port Manageable Gigabit Ethernet Smart Switch, GS724T-600NAS
  • Brand: NETGEAR
  • Part Number: GS724T-600NAS
  • Standards: IEEE 802.3az IEEE 802.1x IEEE 802.1Q IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1ab IEEE 802.3 IEEE 802.3ab IEEE 802.3ae IEEE 802.3ad
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Model #: GS724T-600NAS
  •  
  • $289.99 –
Netgear MS308E Multi-Gigabit (2.5G) Ethernet Easy Smart Managed Essentials Switch, MS308E-100NAS
Quick View
Netgear Inc.
Netgear MS308E Multi-Gigabit (2.5G) Ethernet Easy Smart Managed Essentials Switch, MS308E-100NAS
  • Brand: NETGEAR
  • Part Number: MS308E-100NAS
  • Standards: Networking Standards: IEEE 802.3 IEEE 802.3ab IEEE 802.3u IEEE 802.1p IEEE 802.1Q IEEE 802.3x IEEE 802.3bz IEEE 802.3az IEEE 802.3ad
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: 2.5 Gigabit Ethernet Network Technology: 2.5GBase-T
  • Model #: MS308E-100NAS
  • $229.99
  •  
  • $129.99 –
  • Save: 43%
HPE Aruba Networking 2930F 24G PoE+ 4SFP+ Switch | JL255A
Quick View
HPE Aruba Networking 2930F 24G PoE+ 4SFP+ Switch | JL255A
  • Brand: HPE
  • Part Number: JL255A
  • Primary Ports: (24) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
  • Dimensions: 1.73" x 17.42" x 11.98"
  • Model #: JL255A#ABA
HP JL262A#ABA 2930F 48G PoE+ 4SFP Switch
Quick View
HP JL262A#ABA 2930F 48G PoE+ 4SFP Switch
  • Primary Ports: (48) RJ-45 autosensing 10/100/1000 ports (4) SFP
  • Dimensions: 1.73" x 17.42" x 9.70"
  • Weight: 9.83 lbs.
  • Package Contents: (1) Aruba 2930F 48G PoE+ 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4)bumper feet, (1) cable tie
  • Model #: JL262A#ABA
Cisco Catalyst C1300, 12 x 10 Gigabit copper ports, 2 x 10 Gigabit SFP+, 1 x GE management port, Rack-mountable | C1300-12XT-2X
Quick View
Cisco Catalyst C1300, 12 x 10 Gigabit copper ports, 2 x 10 Gigabit SFP+, 1 x GE management port, Rack-mountable | C1300-12XT-2X
  • Brand: Citrix Systems
  • Series: Catalyst 1300
  • Part Number: C1300-12XT-2X
  • Format: Rackmount
  • Model #: C1300-12XT-2X
BLACK BOX LGH1006A GIGABIT ETHERNET (1000-MBPS) EXTREME TEMPERATURE SWITCH - (4) 10/100/1000-MBPS C
Quick View
BLACK BOX LGH1006A GIGABIT ETHERNET (1000-MBPS) EXTREME TEMPERATURE SWITCH - (4) 10/100/1000-MBPS C
  • Brand: Black Box Corporation
  • Switch Type: Others
  • Weight: 1.3
  • Model #: LGH1006A
  • $319.93 - $330.50
HPE Aruba 2930F 12G PoE+ 2G/2SFP+ Switch  JL693A#ABA
Quick View
HPE Aruba 2930F 12G PoE+ 2G/2SFP+ Switch JL693A#ABA
  • Brand: HPE - SWITCHING
  • Switch Type: managed
  • Model #: JL693AABA
HPE Aruba Networking 2930F 24G PoE+ 4SFP Switch | JL261A
Quick View
HPE Aruba Networking 2930F 24G PoE+ 4SFP Switch | JL261A
  • Primary Ports: (24) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP
  • Dimensions: 1.73" x 17.42" x 11.98"
  • Weight: 8.60 lbs.
  • Package Contents: (1) Aruba 2930F 24G PoE+ 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
  • Model #: JL261A#ABA
FortiSwitch-124G-FPOE Layer 2 FortiGate Switch Controller Compatible PoE Switch with 24x 2.5G/1G/100M RJ45 ports (FS-124G-FPOE)
Quick View
FortiSwitch-124G-FPOE Layer 2 FortiGate Switch Controller Compatible PoE Switch with 24x 2.5G/1G/100M RJ45 ports (FS-124G-FPOE)
  • Brand: Fortinet
  • Series: FortiGate
  • Model: FS-124G-FPOE
  • Part Number: FS-124G-FPOE
  • Model #: FS-124G-FPOE
Aruba 2930F 48GPoE+4SFP+740W Switch
Quick View
Aruba 2930F 48GPoE+4SFP+740W Switch
  • Brand: HPE
  • Switch Type: Others
  • Format: Desktop
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Model #: JL558A#ABA
Fortinet FortiSwitch 248D 48 Port Layer 2/3 Gigabit Ethernet Switch - FS-248D
Quick View
Fortinet FortiSwitch 248D 48 Port Layer 2/3 Gigabit Ethernet Switch - FS-248D
  • Brand: FORTINET INC.
  • Switch Type: ethernet
  • Weight: 10.10
  • Model #: FS-248D
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
Quick View
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
  • Brand: HPE
  • Part Number: JL256A
  • Primary Ports: (48) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
  • Dimensions: 1.73" x 17.42" x 11.98"
  • Model #: JL256A#ABA
Fortinet FortiSwitch-148F-FPOE, Layer 2 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 10G SFP+ ports, 48 port PoE | FS-148F-FPOE
Quick View
Fortinet FortiSwitch-148F-FPOE, Layer 2 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 10G SFP+ ports, 48 port PoE | FS-148F-FPOE
  • Brand: Fortinet
  • Series: 100F series
  • Part Number: FS-148F-FPOE
  • Format: 1 RU Rack Mount
  • Model #: FS-148F-FPOE
  • $1,695.99 - $1,699.99
D-Link 52-Port 10-Gigabit Smart Managed PoE Switch DGS125052XMP6KV
Quick View
D-Link 52-Port 10-Gigabit Smart Managed PoE Switch DGS125052XMP6KV
  • Brand: D-Link
  • Switch Type: managed
  • Model #: DGS125052XMP6KV
Netgear MS308 8-Port 2.5G Multi-Gigabit Ethernet Unmanaged Switch, MS308-100NAS
Quick View
Netgear MS308 8-Port 2.5G Multi-Gigabit Ethernet Unmanaged Switch, MS308-100NAS
  • Brand: NETGEAR
  • Part Number: MS308-100NAS
  • Format: Desktop Wall mount
  • Standards: IEEE 802.3 IEEE 802.3bz IEEE 802.3ab IEEE 802.3u IEEE 802.3az IEEE 802.1p IEEE 802.3x
  • Model #: MS308-100NAS
  • $199.99
  •  
  • $109.99 –
  • Save: 45%
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
  • Part Number: C1300-24XS
  • Format: Rackmount
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 1000Base-T Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-24XS
Cisco Catalyst C1300-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-16P-2G
  • Format: Rail-mountable
  • Model #: C1300-16P-2G
Cisco C1300X-24T-4X Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 3 Layer Supported - 32.10 W Power Consumption - Twisted Pair, Optical Fiber
Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
  • Format: Rackmount
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-52MP
Cisco C1300X-48T-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48T-4X
Quick View
Cisco C1300X-48T-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48T-4X
  • Brand: Cisco Systems, Inc.
  • Series: 1300X Series
  • Part Number: C1300X-48T-4X
  • Format: Rackmount
  • Model #: C1300X-48T-4X
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-16XTS
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1x IEEE 802.3af IEEE 802.3at IEEE 802.1ab IEEE 802.3az
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-16XTS
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-24XTS
  • Format: Rack-mountable
  • Model #: C1300-24XTS
Cisco Catalyst 1300-12XS Managed Switch, 10 Port 10G SFP+, 2x10GE SFP+ Combo, Limited Lifetime Protection (C1300-12XS)
Quick View
Cisco Catalyst 1300-12XS Managed Switch, 10 Port 10G SFP+, 2x10GE SFP+ Combo, Limited Lifetime Protection (C1300-12XS)
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-12XS
  • Switch Type: Manageable
  • Model #: C1300-12XS
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-501T
  •  
  • $114.99 –
Cisco Catalyst 1300 C1300-24XT Layer 3 Switch, 20 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XT Layer 3 Switch, 20 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-24XT
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-24XT
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • $124.99 –
Cisco Business 220 Gigabit Ethernet Switch, 8 x 10/100/1000 ports w/ 130W power budget, 2 x Gigabit SFP | CBS220-8FP-E-2G-NA
Quick View
Cisco Business 220 Gigabit Ethernet Switch, 8 x 10/100/1000 ports w/ 130W power budget, 2 x Gigabit SFP | CBS220-8FP-E-2G-NA
  • Part Number: CBS220-8FP-E-2G
  • Format: Rack-mountable
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.1x IEEE 802.3af IEEE 802.3at
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Model #: CBS2208FPE2GNA
Ruckus ICX7550-48F-E2  Entry-Level Aggregation 48 Ports 1G/10G SFP/SFP+ Managed Rack-Mountable Switch, 2 AC Power Supplies, 3 Fans Exhaust Airflow Installed
Quick View
Ruckus ICX7550-48F-E2 Entry-Level Aggregation 48 Ports 1G/10G SFP/SFP+ Managed Rack-Mountable Switch, 2 AC Power Supplies, 3 Fans Exhaust Airflow Installed
  • Part Number: ICX7550-48F-E2
  • Primary Ports: Interfaces: 36-port 100/1000 Mbps SFP, 12-port 1/10 Gbps SFP+, 2x 40/100Gbps QSFP+, USB Type-C SFP Ports: 36 SFP+ Ports: 12
  • Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
  • Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Power / Provided (W): 400 Watt Max Power Consumption: 166.8 Watt Power / Voltage Required: 100 to 240 VAC
  • Model #: ICX7550-48F-E2
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
  • Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
  • Model #: GS-4210-16P4C
RUCKUS ICX 8100 1RU Switch, 24x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 4x1GbE SFP uplink-ports, 370W PoE budget. Power cord not included | ICX8100-24P
Quick View
RUCKUS ICX 8100 1RU Switch, 48x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 4x10GbE SFP+ uplink-ports, 740W PoE budget, Power cord not included | ICX8100-48PF-X
Quick View
RUCKUS ICX 8100 1RU Switch, 48x10/100/1000 Mbps PoE+ 802.3at, 30W Class 4 ports, 4x10GbE SFP+ uplink-ports, 740W PoE budget, Power cord not included | ICX8100-48PF-X
  • Brand: Ruckus
  • Part Number: ICX8100-48PF-X
  • Format: Rackmount
  • Standards: 802.1AB LLDP/ LLDP-MED 802.1D MAC Bridging 802.1p Mapping to Priority Queue 802.1s Multiple Spanning Tree (MST) 802.1w Rapid Reconfiguration of Spanning Tree (RSTP) 802.1x Port-based Network Access Control (PNAC) 802.3 Carrier Sense Multiple Access/Collision Detection (CSMA/CD) 802.3ab 1000BASE-T 802.3 10Base-T 802.3ad Link Aggregation (Dynamic and Static) 802.1 AX-2008 Link Aggregation 802.3ae 10 Gigabit Ethernet 802.3af Power over Ethernet 802.3at Power over Ethernet Plus 802.3bz Multigigabit Ethernet 802.3u 100Base-TX 802.3x Flow Control 802.3z 1000Base-SX/LX 802.3 MAU MIB (RFC 2239) 802.1Q VLAN Tagging 802.1BR Bridge Port Extension 802.3az Energy Efficient Ethernet 802.3bt PoE++
  • Model #: ICX8100-48PF-X